aboutsummaryrefslogtreecommitdiffstats
path: root/test/headers/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test/headers/meson.build')
-rw-r--r--test/headers/meson.build33
1 files changed, 33 insertions, 0 deletions
diff --git a/test/headers/meson.build b/test/headers/meson.build
new file mode 100644
index 0000000..72d039a
--- /dev/null
+++ b/test/headers/meson.build
@@ -0,0 +1,33 @@
+# Copyright 2020-2025 David Robillard <d@drobilla.net>
+# SPDX-License-Identifier: 0BSD OR ISC
+
+header_c_suppressions = []
+
+if get_option('warning_level') == 'everything'
+ if cc.get_id() == 'clang'
+ if not meson.is_cross_build()
+ header_c_suppressions += ['-Wno-poison-system-directories']
+ endif
+ endif
+endif
+
+test_headers_c_args = header_c_suppressions
+test_headers_c_args += [
+ '-DPUGL_NO_INCLUDE_GL_H',
+ '-DPUGL_NO_INCLUDE_GLU_H',
+]
+
+if vulkan_dep.found()
+ test_headers_c_args += ['-DPUGL_TEST_VULKAN']
+endif
+
+test(
+ 'headers',
+ executable(
+ 'test_headers_c',
+ files('test_headers.c'),
+ c_args: test_headers_c_args,
+ dependencies: pugl_dep,
+ ),
+ suite: 'unit',
+)