aboutsummaryrefslogtreecommitdiffstats
path: root/test/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build10
1 files changed, 10 insertions, 0 deletions
diff --git a/test/meson.build b/test/meson.build
index ac66e92..9de43da 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -1,3 +1,8 @@
+# Copyright 2021 David Robillard <d@drobilla.net>
+# SPDX-License-Identifier: CC0-1.0 OR ISC
+
+reuse = find_program('reuse', required: false)
+
# Suppress some additional C warnings in tests
test_c_args = []
if get_option('strict')
@@ -33,6 +38,11 @@ if get_option('strict') and is_variable('cpp')
test_cpp_args = cpp.get_supported_arguments(test_cpp_args)
endif
+# Check licensing metadata
+if reuse.found()
+ test('REUSE', reuse, args: ['--root', pugl_src_root, 'lint'], suite: 'data')
+endif
+
basic_tests = [
'local_copy_paste',
'realize',