aboutsummaryrefslogtreecommitdiffstats
path: root/doc/c/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2022-06-27 12:59:34 -0400
committerDavid Robillard <d@drobilla.net>2022-07-10 13:39:53 -0400
commit5e78edf6e09373938a796cf44fb38d2309d04b4d (patch)
treee80618e5e092dcb3d9501a2568cf67489fe3d1bd /doc/c/meson.build
parentbcc1c936b15782d8fa59e2ebf471cf686527135c (diff)
downloadserd-5e78edf6e09373938a796cf44fb38d2309d04b4d.tar.gz
serd-5e78edf6e09373938a796cf44fb38d2309d04b4d.tar.bz2
serd-5e78edf6e09373938a796cf44fb38d2309d04b4d.zip
Switch to meson build system
Diffstat (limited to 'doc/c/meson.build')
-rw-r--r--doc/c/meson.build52
1 files changed, 52 insertions, 0 deletions
diff --git a/doc/c/meson.build b/doc/c/meson.build
new file mode 100644
index 00000000..ee104b13
--- /dev/null
+++ b/doc/c/meson.build
@@ -0,0 +1,52 @@
+config = configuration_data()
+config.set('SERD_VERSION', meson.project_version())
+config.set('SERD_SRCDIR', serd_src_root)
+config.set('SERD_TITLE', get_option('title'))
+
+conf_py = configure_file(
+ configuration: config,
+ input: files('../conf.py.in'),
+ output: 'conf.py',
+)
+
+configure_file(
+ copy: true,
+ input: files('../summary.rst'),
+ output: 'summary.rst',
+)
+
+c_rst_files = files(
+ 'index.rst',
+ 'overview.rst',
+)
+
+foreach f : c_rst_files
+ configure_file(copy: true, input: f, output: '@PLAINNAME@')
+endforeach
+
+subdir('xml')
+subdir('api')
+
+# TODO: Add install_tag: 'doc' after requiring meson 0.60.0
+
+custom_target(
+ 'singlehtml',
+ build_by_default: true,
+ command: [sphinx_build, '-M', 'singlehtml', '@OUTDIR@', '@OUTDIR@',
+ '-E', '-q', '-t', 'singlehtml'],
+ input: [c_rst_files, c_serd_rst, c_index_xml],
+ install: true,
+ install_dir: docdir / versioned_name,
+ output: 'singlehtml',
+)
+
+custom_target(
+ 'html',
+ build_by_default: true,
+ command: [sphinx_build, '-M', 'html', '@OUTDIR@', '@OUTDIR@',
+ '-E', '-q', '-t', 'html'],
+ input: [c_rst_files, c_serd_rst, c_index_xml],
+ install: true,
+ install_dir: docdir / versioned_name,
+ output: 'html',
+)