aboutsummaryrefslogtreecommitdiffstats
path: root/doc/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2023-08-31 23:02:14 -0400
committerDavid Robillard <d@drobilla.net>2023-09-22 23:54:50 -0400
commit702830465ac87867fa4051a9be5036ef0b795c13 (patch)
treeb622b24311da2017d3f4904f9a099c467417c32c /doc/meson.build
parentd28682c92d400d5eb5a2ef19d4b88c34bfcf5eea (diff)
downloadserd-702830465ac87867fa4051a9be5036ef0b795c13.tar.gz
serd-702830465ac87867fa4051a9be5036ef0b795c13.tar.bz2
serd-702830465ac87867fa4051a9be5036ef0b795c13.zip
Move man pages to their own directory
Diffstat (limited to 'doc/meson.build')
-rw-r--r--doc/meson.build51
1 files changed, 6 insertions, 45 deletions
diff --git a/doc/meson.build b/doc/meson.build
index b492483d..7180ec28 100644
--- a/doc/meson.build
+++ b/doc/meson.build
@@ -4,6 +4,12 @@
docdir = get_option('datadir') / 'doc'
#############
+# Man pages #
+#############
+
+subdir('man')
+
+#############
# Reference #
#############
@@ -65,48 +71,3 @@ if build_docs
endif
endforeach
endif
-
-#############
-# Man Pages #
-#############
-
-mandoc_css = files('mandoc.css')
-
-if get_option('lint')
- stylelint = find_program('stylelint', required: false)
- if stylelint.found()
- test('stylelint', stylelint, args: [mandoc_css], suite: 'data')
- endif
-endif
-
-mandoc = find_program('mandoc', required: false)
-if mandoc.found()
- configure_file(input: mandoc_css, output: '@PLAINNAME@', copy: true)
-
- serdi_html = custom_target(
- 'serdi.html',
- build_by_default: true,
- capture: true,
- command: [
- mandoc,
- '-Kutf-8',
- '-Ostyle=mandoc.css,man=%N.html',
- '-Thtml',
- '-Wwarning,stop',
- '@INPUT@',
- ],
- input: files('serdi.1'),
- output: 'serdi.html',
- )
-endif
-
-if not meson.is_subproject()
- summary(
- {
- 'HTML man pages': mandoc.found(),
- 'API documentation': build_docs,
- },
- bool_yn: true,
- section: 'Components',
- )
-endif