aboutsummaryrefslogtreecommitdiffstats
path: root/doc/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2022-12-04 13:46:03 -0500
committerDavid Robillard <d@drobilla.net>2022-12-08 19:08:23 -0500
commit9a222ac2ae6b4dac6dd8a414498523f472e90279 (patch)
tree5a84ca096a90093e1fd2c1ba359ce239f422a65a /doc/meson.build
parent77353fba14db23f3919bebc392dab7ff3ea02010 (diff)
downloadserd-9a222ac2ae6b4dac6dd8a414498523f472e90279.tar.gz
serd-9a222ac2ae6b4dac6dd8a414498523f472e90279.tar.bz2
serd-9a222ac2ae6b4dac6dd8a414498523f472e90279.zip
Replace duplicated dox_to_sphinx script with sphinxygen dependency
Diffstat (limited to 'doc/meson.build')
-rw-r--r--doc/meson.build9
1 files changed, 7 insertions, 2 deletions
diff --git a/doc/meson.build b/doc/meson.build
index b97ba610..e1a20aa4 100644
--- a/doc/meson.build
+++ b/doc/meson.build
@@ -4,11 +4,16 @@
docdir = get_option('datadir') / 'doc'
doxygen = find_program('doxygen', required: get_option('docs'))
-dox_to_sphinx = files('../scripts/dox_to_sphinx.py')
+sphinxygen = find_program('sphinxygen', required: false)
sphinx_build = find_program('sphinx-build', required: get_option('docs'))
mandoc = find_program('mandoc', required: false)
-build_docs = doxygen.found() and sphinx_build.found()
+if not sphinxygen.found()
+ subproject('sphinxygen')
+ sphinxygen = find_program('sphinxygen', required: get_option('docs'))
+endif
+
+build_docs = doxygen.found() and sphinxygen.found() and sphinx_build.found()
if build_docs
subdir('c')