aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2023-09-10 15:06:42 -0400
committerDavid Robillard <d@drobilla.net>2023-12-02 18:49:08 -0500
commit248a874d7425749d29cf900a1c3783c624ea8d8c (patch)
treeaed59f5a484a815cd254506866e98a947858904d /meson.build
parent0bd10132c6707353dba80bd89cf0102ee7ca4e34 (diff)
downloadserd-248a874d7425749d29cf900a1c3783c624ea8d8c.tar.gz
serd-248a874d7425749d29cf900a1c3783c624ea8d8c.tar.bz2
serd-248a874d7425749d29cf900a1c3783c624ea8d8c.zip
Add support for custom allocators
This makes it explicit in the API where memory is allocated, and allows the user to provide a custom allocator to avoid the use of the default system allocator for whatever reason.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 1 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index 4cf4e8d6..ad745658 100644
--- a/meson.build
+++ b/meson.build
@@ -88,10 +88,6 @@ else
'fcntl.h',
'posix_fadvise(0, 0, 4096, POSIX_FADV_SEQUENTIAL);',
],
- 'posix_memalign': [
- 'stdlib.h',
- 'void* mem=NULL; posix_memalign(&mem, 8U, 8U);',
- ],
'strerror_r': [
'string.h',
'char buf[128]; return strerror_r(0, &buf, sizeof(buf));',
@@ -165,6 +161,7 @@ sources = files(
'src/env.c',
'src/input_stream.c',
'src/log.c',
+ 'src/memory.c',
'src/node.c',
'src/output_stream.c',
'src/read_nquads.c',