aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2022-07-13 17:55:16 -0400
committerDavid Robillard <d@drobilla.net>2023-12-02 18:49:08 -0500
commit91c0c68e153118f4d64c137d78882ee95830c307 (patch)
tree1325868b64aab19ff57a08d528ac1a25b8e82d7a /meson.build
parent90fe1b64c2203f9e82646cb41c8a85f0a31125bb (diff)
downloadserd-91c0c68e153118f4d64c137d78882ee95830c307.tar.gz
serd-91c0c68e153118f4d64c137d78882ee95830c307.tar.bz2
serd-91c0c68e153118f4d64c137d78882ee95830c307.zip
Move serdi to tools subdirectory
This separates the command-line tool code from the library implementation.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build19
1 files changed, 1 insertions, 18 deletions
diff --git a/meson.build b/meson.build
index 66ef536f..2c440224 100644
--- a/meson.build
+++ b/meson.build
@@ -234,24 +234,7 @@ install_headers(c_headers, subdir: versioned_name / 'serd')
# Build serdi command line utility
if not get_option('tools').disabled()
- tool_link_args = []
- if get_option('static')
- tool_link_args += ['-static']
- endif
-
- serdi = executable(
- 'serdi',
- files(
- 'src/console.c',
- 'src/serdi.c',
- ),
- c_args: c_suppressions + platform_c_args,
- dependencies: [serd_dep, zix_dep],
- install: true,
- link_args: tool_link_args,
- )
-
- meson.override_find_program('serdi', serdi)
+ subdir('tools')
endif
# Display top-level summary (before subdirectories to appear first)