aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2021-04-15 18:34:17 -0400
committerDavid Robillard <d@drobilla.net>2023-12-02 18:49:06 -0500
commita970f06aba98736223214a6fa995f4e82acd7132 (patch)
treefc243e4bf26f4c1f95df6f62abdd6740d87d8afd /meson.build
parent44feb2724a8fe34992999867f5b6468228b6fc01 (diff)
downloadserd-a970f06aba98736223214a6fa995f4e82acd7132.tar.gz
serd-a970f06aba98736223214a6fa995f4e82acd7132.tar.bz2
serd-a970f06aba98736223214a6fa995f4e82acd7132.zip
[WIP] Use exess for reading and writing numeric and binary literals
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build12
1 files changed, 11 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index a4b7d168..faf2f2fd 100644
--- a/meson.build
+++ b/meson.build
@@ -98,6 +98,16 @@ else
endforeach
endif
+################
+# Dependencies #
+################
+
+exess_dep = dependency(
+ 'exess-0',
+ fallback: ['exess', 'exess_dep'],
+ version: '>= 0.0.1',
+)
+
###########
# Library #
###########
@@ -157,7 +167,7 @@ libserd = library(
'-DSERD_MINOR_VERSION=@0@'.format(serd_minor_version),
'-DSERD_VERSION="@0@"'.format(meson.project_version()),
] + c_suppressions + extra_c_args + platform_c_args,
- dependencies: m_dep,
+ dependencies: [exess_dep, m_dep],
gnu_symbol_visibility: 'hidden',
include_directories: include_dirs,
install: true,