aboutsummaryrefslogtreecommitdiffstats
path: root/test/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2023-03-31 14:20:03 -0400
committerDavid Robillard <d@drobilla.net>2023-12-02 18:49:07 -0500
commit09bf03fd6e522d6e421fed85d010057f87486544 (patch)
tree837adc1381f0e19e7cbab246be81de5fb6f1bf50 /test/meson.build
parent2f490c80f9623ac2deaeb37a29fc98d01eb20e7e (diff)
downloadserd-09bf03fd6e522d6e421fed85d010057f87486544.tar.gz
serd-09bf03fd6e522d6e421fed85d010057f87486544.tar.bz2
serd-09bf03fd6e522d6e421fed85d010057f87486544.zip
Add empty syntax type for suppressing output
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build10
1 files changed, 10 insertions, 0 deletions
diff --git a/test/meson.build b/test/meson.build
index 2ed73e63..97e082e0 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -16,6 +16,7 @@ simple_script_paths = [
'../scripts/check_formatting.py',
'serd_test_util/__init__.py',
'run_suite.py',
+ 'test_empty.py',
'test_quiet.py',
'test_stdin.py',
'test_write_error.py',
@@ -256,6 +257,15 @@ if is_variable('serdi')
suite: input_suite,
)
+ # Output
+
+ test(
+ 'empty',
+ files('test_empty.py'),
+ args: script_args + [serd_ttl],
+ env: test_env,
+ suite: 'output',
+ )
# IO errors