aboutsummaryrefslogtreecommitdiffstats
path: root/test/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2021-10-09 13:44:31 -0400
committerDavid Robillard <d@drobilla.net>2023-12-02 18:49:08 -0500
commit0bd10132c6707353dba80bd89cf0102ee7ca4e34 (patch)
tree6ddefca863cb7dc50f539899dde6def80043601d /test/meson.build
parent66c589578eb9b9dc89da6a34d274627f7f2435d7 (diff)
downloadserd-0bd10132c6707353dba80bd89cf0102ee7ca4e34.tar.gz
serd-0bd10132c6707353dba80bd89cf0102ee7ca4e34.tar.bz2
serd-0bd10132c6707353dba80bd89cf0102ee7ca4e34.zip
Test handling of deferred write errors that happen when closing
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build8
1 files changed, 8 insertions, 0 deletions
diff --git a/test/meson.build b/test/meson.build
index 08fb3200..dde17566 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -214,6 +214,7 @@ if is_variable('serd_pipe')
pipe_script_args = common_script_args + ['--tool', serd_pipe]
serd_ttl = files('../serd.ttl')[0]
bad_input_file = files('extra/bad/bad-lang.ttl')
+ small_ttl = files('w3c/turtle/turtle-syntax-number-01.ttl')
test('serd_ttl', serd_pipe, args: [serd_ttl], env: test_env, suite: 'data')
@@ -353,6 +354,13 @@ if is_variable('serd_pipe')
suite: 'io',
)
test(
+ 'deferred_write_error',
+ files('test_write_error.py'),
+ args: pipe_script_args + [small_ttl, '--', '-b', '1024'],
+ env: test_env,
+ suite: 'io',
+ )
+ test(
'missing_output',
serd_pipe,
args: ['-o', '/does/not/exist.ttl', serd_ttl],