aboutsummaryrefslogtreecommitdiffstats
path: root/test/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2021-01-13 20:00:25 +0100
committerDavid Robillard <d@drobilla.net>2023-12-02 18:49:08 -0500
commit456bdeef35ffbfbdad7609e8b8a4ef71372786fd (patch)
tree25fabaa4f361f66a2bac860f06722e7f51776cbc /test/meson.build
parentfc2114a10769349d38b3215bc95ded855a2be5b6 (diff)
downloadserd-456bdeef35ffbfbdad7609e8b8a4ef71372786fd.tar.gz
serd-456bdeef35ffbfbdad7609e8b8a4ef71372786fd.tar.bz2
serd-456bdeef35ffbfbdad7609e8b8a4ef71372786fd.zip
[WIP] Add extensible logging API
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build29
1 files changed, 27 insertions, 2 deletions
diff --git a/test/meson.build b/test/meson.build
index a2436b22..01f75b5a 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -127,6 +127,7 @@ unit_tests = [
'caret',
'env',
'free_null',
+ 'log',
'node',
'overflow',
'reader',
@@ -210,7 +211,7 @@ simple_command_tests = {
if is_variable('serd_pipe')
pipe_script_args = common_script_args + ['--tool', serd_pipe]
serd_ttl = files('../serd.ttl')[0]
- bad_input_file = files('extra/bad/bad-base.ttl')
+ bad_input_file = files('extra/bad/bad-lang.ttl')
test('serd_ttl', serd_pipe, args: [serd_ttl], env: test_env, suite: 'data')
@@ -250,7 +251,31 @@ if is_variable('serd_pipe')
files('test_quiet.py'),
args: pipe_script_args + [bad_input_file],
env: test_env,
- suite: cmd_suite,
+ suite: 'log',
+ )
+ test(
+ 'CLICOLOR_FORCE',
+ serd_pipe,
+ args: bad_input_file,
+ env: test_env + ['CLICOLOR_FORCE=1'],
+ should_fail: true,
+ suite: 'log',
+ )
+ test(
+ 'CLICOLOR',
+ serd_pipe,
+ args: bad_input_file,
+ env: test_env + ['CLICOLOR=0'],
+ should_fail: true,
+ suite: 'log',
+ )
+ test(
+ 'NO_COLOR',
+ serd_pipe,
+ args: bad_input_file,
+ env: test_env + ['NO_COLOR=1'],
+ should_fail: true,
+ suite: 'log',
)
# Inputs