aboutsummaryrefslogtreecommitdiffstats
path: root/test/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2023-12-01 18:31:30 -0500
committerDavid Robillard <d@drobilla.net>2023-12-02 18:49:08 -0500
commit94879f376f1d2b8fbb2322bf2a7dab5c3bb9e098 (patch)
tree6db087ffdb3c76fac0492b771bc25aee6291a3e7 /test/meson.build
parented12fd8066ed47c1ee675a69dfed21751313f197 (diff)
downloadserd-94879f376f1d2b8fbb2322bf2a7dab5c3bb9e098.tar.gz
serd-94879f376f1d2b8fbb2322bf2a7dab5c3bb9e098.tar.bz2
serd-94879f376f1d2b8fbb2322bf2a7dab5c3bb9e098.zip
[TESTED] Replace -b and -e options with a block size option
This is more powerful, and reduces the number of command line options that almost nobody needs to care about.
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build8
1 files changed, 6 insertions, 2 deletions
diff --git a/test/meson.build b/test/meson.build
index 489a6ee5..e6b0fe5c 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -176,6 +176,10 @@ simple_command_tests = {
'bad': [
['-B', 'nonuriorpath'],
['-B'],
+ ['-b', '-1'],
+ ['-b', '1024junk'],
+ ['-b', '9223372036854775807'],
+ ['-b'],
['-c'],
['-fi'],
['-i', 'turtle'],
@@ -298,7 +302,7 @@ if is_variable('serd_pipe')
io_error_tests = {
'read_dir_bulk': [serd_src_root],
- 'read_dir_bytes': ['-e', serd_src_root],
+ 'read_dir_bytes': ['-b', '1', serd_src_root],
'read_dir_uri': ['file://@0@/'.format(serd_src_root)],
}
@@ -394,7 +398,7 @@ test_suites = {
ns_serdtest + 'good/',
'--',
'-a',
- '-b',
+ ['-b', '1'],
],
'fast': [
files('extra/perfect/manifest.ttl'),