aboutsummaryrefslogtreecommitdiffstats
path: root/test/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2024-06-24 15:12:05 -0400
committerDavid Robillard <d@drobilla.net>2024-06-25 15:54:43 -0400
commit51cc405d288a078543523efd380ce3c7d11ac501 (patch)
tree48d3b3263e966cc46c0667fd40212304cb70cbde /test/meson.build
parent2f51df8eed40bb808dce0ce1d5ba218a1b2b0071 (diff)
downloadserd-51cc405d288a078543523efd380ce3c7d11ac501.tar.gz
serd-51cc405d288a078543523efd380ce3c7d11ac501.tar.bz2
serd-51cc405d288a078543523efd380ce3c7d11ac501.zip
Improve test suite coverage
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/test/meson.build b/test/meson.build
index fe476491..ab012908 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -153,15 +153,20 @@ simple_command_tests = {
'serdi': {
'bad': [
['-c'],
+ ['-cx'],
['-fi'],
['-i', 'turtle'],
['-i', 'turt'],
['-i'],
+ ['-ix'],
['-o', '~unknown'],
['-o', 'ntripleses'],
['-o'],
+ ['-ox'],
['-p'],
+ ['-px'],
['-r'],
+ ['-rx'],
['-z'],
],
'good': [
@@ -178,6 +183,7 @@ if is_variable('serdi')
script_args = common_script_args + ['--serdi', serdi]
serd_ttl = files('../serd.ttl')[0]
bad_input_file = files('extra/bad/bad-base.ttl')
+ text_input_file = files('extra/bad/README.md')
test('serd_ttl', serdi, args: [serd_ttl], suite: 'data')
@@ -214,6 +220,7 @@ if is_variable('serdi')
'string': ['-s', '<foo> a <Bar> .'],
'no_such_file': ['no_such_file'],
'remote': ['ftp://example.org/unsupported.ttl'],
+ 'text': [text_input_file],
}
foreach name, args : bad_input_tests