aboutsummaryrefslogtreecommitdiffstats
path: root/tools/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2022-07-13 17:55:16 -0400
committerDavid Robillard <d@drobilla.net>2023-12-02 18:49:08 -0500
commit91c0c68e153118f4d64c137d78882ee95830c307 (patch)
tree1325868b64aab19ff57a08d528ac1a25b8e82d7a /tools/meson.build
parent90fe1b64c2203f9e82646cb41c8a85f0a31125bb (diff)
downloadserd-91c0c68e153118f4d64c137d78882ee95830c307.tar.gz
serd-91c0c68e153118f4d64c137d78882ee95830c307.tar.bz2
serd-91c0c68e153118f4d64c137d78882ee95830c307.zip
Move serdi to tools subdirectory
This separates the command-line tool code from the library implementation.
Diffstat (limited to 'tools/meson.build')
-rw-r--r--tools/meson.build23
1 files changed, 23 insertions, 0 deletions
diff --git a/tools/meson.build b/tools/meson.build
new file mode 100644
index 00000000..49fa32c7
--- /dev/null
+++ b/tools/meson.build
@@ -0,0 +1,23 @@
+# Copyright 2021-2022 David Robillard <d@drobilla.net>
+# SPDX-License-Identifier: 0BSD OR ISC
+
+tool_c_args = c_suppressions + platform_c_args
+tool_link_args = []
+
+if get_option('static') and cc.get_id() != 'msvc'
+ tool_link_args += ['-static']
+endif
+
+serdi = executable(
+ 'serdi',
+ files(
+ 'console.c',
+ 'serdi.c',
+ ),
+ c_args: tool_c_args,
+ dependencies: [serd_dep, zix_dep],
+ install: true,
+ link_args: tool_link_args,
+)
+
+meson.override_find_program('serdi', serdi)