aboutsummaryrefslogtreecommitdiffstats
path: root/test/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/test/meson.build b/test/meson.build
index e31ddef3..0104079f 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -46,6 +46,12 @@ if get_option('lint')
test(name, black, args: black_opts + [script], suite: 'scripts')
endforeach
endif
+
+ # Check scripts for errors with flake8
+ flake8 = find_program('flake8', required: false)
+ if flake8.found()
+ test('flake8', flake8, args: python_scripts, suite: 'scripts')
+ endif
endif
###################