aboutsummaryrefslogtreecommitdiffstats
path: root/test/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build11
1 files changed, 11 insertions, 0 deletions
diff --git a/test/meson.build b/test/meson.build
index e0aea675..496296c1 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -289,6 +289,17 @@ if is_variable('serdi')
env: test_env,
suite: 'io',
)
+
+ if host_machine.system() == 'linux'
+ test(
+ 'unreadable',
+ serdi,
+ args: ['/sys/bus/pci/rescan'],
+ env: test_env,
+ should_fail: true,
+ suite: 'io',
+ )
+ endif
endif
###########################