summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2021-04-01 14:14:32 -0400
committerDavid Robillard <d@drobilla.net>2021-04-01 14:14:32 -0400
commitec134d2c5f2c44a602ede280f9ce7dffd64caf41 (patch)
tree873f615a95280a860ae6f15254381bb3c7a920b6 /meson.build
parent91945867cfee9e92df50149311d98eda41b16a60 (diff)
downloadsratom-ec134d2c5f2c44a602ede280f9ce7dffd64caf41.tar.gz
sratom-ec134d2c5f2c44a602ede280f9ce7dffd64caf41.tar.bz2
sratom-ec134d2c5f2c44a602ede280f9ce7dffd64caf41.zip
WIP
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build11
1 files changed, 7 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index c85b966..57498a2 100644
--- a/meson.build
+++ b/meson.build
@@ -53,6 +53,9 @@ if get_option('strict')
'-Wno-suggest-attribute=pure',
'-Wno-unsuffixed-float-constants',
'-Wno-unused-const-variable',
+
+ # FIXME: Just for tests
+ '-Wno-parentheses',
]
elif cc.get_id() == 'msvc'
c_warnings += [
@@ -84,8 +87,8 @@ if cc.get_id() == 'msvc'
add_project_arguments(msvc_args, language: ['c'])
endif
-c_headers = ['include/sratom/sratom.h']
-c_header_files = files(c_headers)
+sratom_c_headers = ['include/sratom/sratom.h']
+sratom_c_header_files = files(sratom_c_headers)
sources = [
'src/dumper.c',
@@ -150,7 +153,7 @@ pkg.generate(
description: 'A library for serializing LV2 atoms')
# Install header to a versioned include directory
-install_headers(c_headers, subdir: versioned_name / 'sratom')
+install_headers(sratom_c_header_files, subdir: versioned_name / 'sratom')
if not get_option('docs').disabled()
subdir('doc')
@@ -165,7 +168,7 @@ if is_variable('cpp')
subdir('bindings/cpp')
endif
-if meson.version().version_compare('>=0.53.0')
+if not meson.is_subproject() and meson.version().version_compare('>=0.53.0')
summary('Tests', get_option('tests'), bool_yn: true)
summary('Install prefix', get_option('prefix'))