summaryrefslogtreecommitdiffstats
path: root/test/headers/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test/headers/meson.build')
-rw-r--r--test/headers/meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/test/headers/meson.build b/test/headers/meson.build
index aed2e43..b5d7c71 100644
--- a/test/headers/meson.build
+++ b/test/headers/meson.build
@@ -3,12 +3,13 @@
header_c_suppressions = []
-if get_option('strict')
+if get_option('warning_level') == 'everything'
if cc.get_id() == 'clang'
header_c_suppressions += [
'-Wno-cast-align', # LV2
'-Wno-cast-qual', # LV2
'-Wno-declaration-after-statement', # LV2
+ '-Wno-padded', # LV2, serd
]
elif cc.get_id() == 'gcc'
header_c_suppressions += [