summaryrefslogtreecommitdiffstats
path: root/doc/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'doc/meson.build')
-rw-r--r--doc/meson.build11
1 files changed, 7 insertions, 4 deletions
diff --git a/doc/meson.build b/doc/meson.build
index b6f6402..4db8c74 100644
--- a/doc/meson.build
+++ b/doc/meson.build
@@ -44,9 +44,12 @@ if build_docs
)
# Copy hand-written documentation files
- c_rst_files = files('index.rst', 'overview.rst')
- foreach f : c_rst_files
- configure_file(copy: true, input: f, output: '@PLAINNAME@')
+ rst_sources = files('index.rst', 'overview.rst')
+ sphinx_input = []
+ foreach f : rst_sources
+ sphinx_input += [
+ configure_file(copy: true, input: f, output: '@PLAINNAME@'),
+ ]
endforeach
# Generate reference documentation input with Doxygen and Sphinxygen
@@ -55,7 +58,7 @@ if build_docs
# Build strict Sphinx flags, with termination on warnings if werror=true
sphinx_in_dir = meson.current_build_dir()
- sphinx_flags = ['-d', sphinx_in_dir / '.doctrees', '-E', '-a', '-q']
+ sphinx_flags = ['-E', '-a', '-q']
if get_option('werror')
sphinx_flags += ['-W']
endif