summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 9b02789..781a9d4 100644
--- a/meson.build
+++ b/meson.build
@@ -38,15 +38,16 @@ if get_option('strict')
'-Wno-disabled-macro-expansion',
'-Wno-padded',
'-Wno-reserved-id-macro',
+ '-Wno-reserved-identifier', # Glib headers
'-Wno-variadic-macros',
]
elif cc.get_id() == 'gcc'
c_warnings += [
+ '-Wno-extra-semi', # Qt headers
'-Wno-padded',
'-Wno-pragmas',
'-Wno-suggest-attribute=const',
'-Wno-suggest-attribute=pure',
- '-Wno-extra-semi', # Qt headers
]
elif cc.get_id() == 'msvc'
c_warnings += [