summaryrefslogtreecommitdiffstats
path: root/meson/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson/meson.build')
-rw-r--r--meson/meson.build46
1 files changed, 38 insertions, 8 deletions
diff --git a/meson/meson.build b/meson/meson.build
index 20e0522..99d54d2 100644
--- a/meson/meson.build
+++ b/meson/meson.build
@@ -181,16 +181,46 @@ if is_variable('cpp')
endif
endif
-# Set all_objc_warnings for the current Objective C compiler
-if is_variable('objcc')
- all_objc_warnings = []
- if objcc.get_id() == 'clang'
- all_objc_warnings = ['-Weverything']
- elif objc.get_id() == 'gcc'
- all_objc_warnings = gcc_common_warnings + [
+# Set all_objcpp_warnings for the current Objective C++ compiler
+if is_variable('objcpp')
+ all_objcpp_warnings = []
+ if objcpp.get_id() == 'clang'
+ all_objcpp_warnings = ['-Weverything']
+ elif objcpp.get_id() == 'gcc'
+ all_objcpp_warnings = gcc_common_warnings + [
'-Wno-direct-ivar-access',
]
else
- all_objc_warnings = []
+ all_objcpp_warnings = gcc_common_warnings + [
+ '-Wabi-tag',
+ '-Waligned-new=all',
+ '-Wcatch-value=3',
+ '-Wcomma-subscript',
+ '-Wconditionally-supported',
+ '-Wctor-dtor-privacy',
+ '-Wdeprecated-copy-dtor',
+ '-Weffc++',
+ '-Wextra-semi',
+ '-Wmismatched-tags',
+ '-Wmultiple-inheritance',
+ '-Wno-direct-ivar-access',
+ '-Wnoexcept',
+ '-Wnoexcept-type',
+ '-Wnon-virtual-dtor',
+ '-Wold-style-cast',
+ '-Woverloaded-virtual',
+ '-Wplacement-new=2',
+ '-Wredundant-tags',
+ '-Wregister',
+ '-Wsign-promo',
+ '-Wstrict-null-sentinel',
+ '-Wsuggest-final-methods',
+ '-Wsuggest-final-types',
+ '-Wsuggest-override',
+ '-Wuseless-cast',
+ '-Wvirtual-inheritance',
+ '-Wvolatile',
+ '-Wzero-as-null-pointer-constant',
+ ]
endif
endif