summaryrefslogtreecommitdiffstats
path: root/doc/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2022-12-04 11:02:02 -0500
committerDavid Robillard <d@drobilla.net>2022-12-04 11:02:02 -0500
commit9d652e28f4de41fe3280d6bd4a4b80270d1d655b (patch)
treef469d4c92a0ca8fb46961c9dcd0c4030ae407654 /doc/meson.build
parent94ee6538f7a7790854ce33a68adf0834a27a232b (diff)
downloadzix-9d652e28f4de41fe3280d6bd4a4b80270d1d655b.tar.gz
zix-9d652e28f4de41fe3280d6bd4a4b80270d1d655b.tar.bz2
zix-9d652e28f4de41fe3280d6bd4a4b80270d1d655b.zip
Fall back to alabaster if sphinx_lv2_theme is unavailable
Diffstat (limited to 'doc/meson.build')
-rw-r--r--doc/meson.build12
1 files changed, 12 insertions, 0 deletions
diff --git a/doc/meson.build b/doc/meson.build
index 74c66f2..4f316a3 100644
--- a/doc/meson.build
+++ b/doc/meson.build
@@ -15,6 +15,18 @@ endif
build_docs = doxygen.found() and sphinxygen.found() and sphinx_build.found()
if build_docs
+ # Check for Sphinx LV2 theme
+
+ pymod = import('python')
+ sphinx_lv2_theme_python = pymod.find_installation(
+ modules: ['sphinx_lv2_theme'],
+ required: false
+ )
+
+ if not sphinx_lv2_theme_python.found()
+ warning('Missing sphinx_lv2_theme module, falling back to alabaster')
+ endif
+
# Documentation Code
if not get_option('tests').disabled()