summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2021-12-17 17:55:43 -0500
committerDavid Robillard <d@drobilla.net>2021-12-17 17:55:43 -0500
commit6e797163bb07163026c77d9d328dee9e41f3a54f (patch)
treefd9b1a2e53831b83f2029df003580d54f0c2e12c /meson.build
parent7b1843dfdf5629a087f1659aba2f35d9c2a3ee6b (diff)
downloadzix-6e797163bb07163026c77d9d328dee9e41f3a54f.tar.gz
zix-6e797163bb07163026c77d9d328dee9e41f3a54f.tar.bz2
zix-6e797163bb07163026c77d9d328dee9e41f3a54f.zip
Suppress warning in glib headers
This should really be done more precisely, but I can't be bothered.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 39ccf29..662ee96 100644
--- a/meson.build
+++ b/meson.build
@@ -44,9 +44,10 @@ if get_option('strict')
c_warnings += [
'-Weverything',
'-Wno-bad-function-cast',
+ '-Wno-c11-extensions', # Glib
+ '-Wno-implicit-fallthrough', # Really for clang < 12
'-Wno-padded',
'-Wno-reserved-id-macro',
- '-Wno-implicit-fallthrough', # Really for clang < 12
]
elif cc.get_id() == 'gcc'
c_warnings += [