summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2024-12-11 00:38:17 -0500
committerDavid Robillard <d@drobilla.net>2024-12-11 00:38:17 -0500
commitc3caeb9305dea922bfe3ed71e006e567bb25ecb2 (patch)
tree9e436ea7d03ad33870b8b6c002047a92770bac72 /meson.build
parentc5c23c3e27ab765c8df28088fbec5f41b89bb8b8 (diff)
downloadzix-c3caeb9305dea922bfe3ed71e006e567bb25ecb2.tar.gz
zix-c3caeb9305dea922bfe3ed71e006e567bb25ecb2.tar.bz2
zix-c3caeb9305dea922bfe3ed71e006e567bb25ecb2.zip
Handle emscripten and MinGW stubs the same way
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index d4b9fcd..96a6d27 100644
--- a/meson.build
+++ b/meson.build
@@ -308,6 +308,11 @@ int main(void) { sem_t s; struct timespec t; return sem_timedwait(&s, &t); }''',
continue
endif
+ if cc.get_id() == 'emscripten' and name in ['flock', 'fileno']
+ message('Ignoring emscripten stub @0@'.format(name))
+ continue
+ endif
+
if cc.links(check_code, args: check_c_args, name: name)
platform_c_args += ['-DHAVE_@0@'.format(name.to_upper())]
endif