summaryrefslogtreecommitdiffstats
path: root/scripts/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2022-12-03 16:14:41 -0500
committerDavid Robillard <d@drobilla.net>2022-12-03 16:14:41 -0500
commitc41ebbc08687b5c072108885b7fab66512917d9b (patch)
treeaa6fb2b03623c52842c6ce375fb3d5c8973d6cf7 /scripts/meson.build
parent577356481bbcb12468bcf669ef7107dfb057b833 (diff)
downloadzix-c41ebbc08687b5c072108885b7fab66512917d9b.tar.gz
zix-c41ebbc08687b5c072108885b7fab66512917d9b.tar.bz2
zix-c41ebbc08687b5c072108885b7fab66512917d9b.zip
Replace duplicated dox_to_sphinx script with sphinxygen dependency
Diffstat (limited to 'scripts/meson.build')
-rw-r--r--scripts/meson.build6
1 files changed, 2 insertions, 4 deletions
diff --git a/scripts/meson.build b/scripts/meson.build
index 5b04f99..be6f5e8 100644
--- a/scripts/meson.build
+++ b/scripts/meson.build
@@ -6,9 +6,7 @@ if get_option('strict') and not meson.is_subproject()
pylint = find_program('pylint', required: get_option('tests'))
black = find_program('black', required: get_option('tests'))
- strict_scripts = files('benchmark.py', 'plot.py')
- linty_scripts = files('dox_to_sphinx.py')
- all_scripts = strict_scripts + linty_scripts
+ all_scripts = files('benchmark.py', 'plot.py')
if is_variable('black') and black.found()
black_opts = ['-l', '79', '-q', '--check']
@@ -20,6 +18,6 @@ if get_option('strict') and not meson.is_subproject()
endif
if is_variable('pylint') and pylint.found()
- test('pylint', pylint, args: strict_scripts, suite: 'scripts')
+ test('pylint', pylint, args: all_scripts, suite: 'scripts')
endif
endif