summaryrefslogtreecommitdiffstats
path: root/doc/html/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'doc/html/meson.build')
-rw-r--r--doc/html/meson.build13
1 files changed, 6 insertions, 7 deletions
diff --git a/doc/html/meson.build b/doc/html/meson.build
index fb84a04..9931028 100644
--- a/doc/html/meson.build
+++ b/doc/html/meson.build
@@ -6,13 +6,12 @@ html_dir = docdir / versioned_name / 'html'
custom_target(
'html',
build_by_default: true,
- command: [
- sphinx_build,
- '-M', 'html',
- '@OUTDIR@' / '..',
- '@OUTDIR@' / '..',
+ command: sphinx_build_command + [
+ '-b', 'html',
'-t', 'html',
- ] + sphinx_flags,
+ sphinx_in_dir,
+ '@OUTDIR@'
+ ],
input: [api_zix_rst, conf_py, sphinx_input],
install: true,
install_dir: html_dir,
@@ -31,7 +30,7 @@ custom_target(
if not meson.is_subproject()
summary(
- 'Paginated HTML',
+ 'HTML',
get_option('prefix') / html_dir,
section: 'Directories',
)