summaryrefslogtreecommitdiffstats
path: root/doc/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'doc/meson.build')
-rw-r--r--doc/meson.build14
1 files changed, 12 insertions, 2 deletions
diff --git a/doc/meson.build b/doc/meson.build
index e08de60..74c66f2 100644
--- a/doc/meson.build
+++ b/doc/meson.build
@@ -42,7 +42,6 @@ if build_docs
)
c_doc_files = c_rst_files + files(
- 'conf.py',
'overview_code.c',
)
@@ -50,6 +49,17 @@ if build_docs
configure_file(copy: true, input: f, output: '@PLAINNAME@')
endforeach
+ config = configuration_data()
+ config.set('ZIX_VERSION', meson.project_version())
+ config.set('ZIX_SRCDIR', zix_src_root)
+ config.set('ZIX_TITLE', get_option('title'))
+
+ conf_py = configure_file(
+ configuration: config,
+ input: files('conf.py.in'),
+ output: 'conf.py',
+ )
+
subdir('xml')
subdir('api')
@@ -61,7 +71,7 @@ if build_docs
'-q',
]
- doc_inputs = c_rst_files + [c_zix_rst, c_index_xml]
+ doc_inputs = c_rst_files + [conf_py, c_zix_rst, c_index_xml]
custom_target(
'singlehtml',