summaryrefslogtreecommitdiffstats
path: root/doc/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'doc/meson.build')
-rw-r--r--doc/meson.build12
1 files changed, 12 insertions, 0 deletions
diff --git a/doc/meson.build b/doc/meson.build
index 74c66f2..4f316a3 100644
--- a/doc/meson.build
+++ b/doc/meson.build
@@ -15,6 +15,18 @@ endif
build_docs = doxygen.found() and sphinxygen.found() and sphinx_build.found()
if build_docs
+ # Check for Sphinx LV2 theme
+
+ pymod = import('python')
+ sphinx_lv2_theme_python = pymod.find_installation(
+ modules: ['sphinx_lv2_theme'],
+ required: false
+ )
+
+ if not sphinx_lv2_theme_python.found()
+ warning('Missing sphinx_lv2_theme module, falling back to alabaster')
+ endif
+
# Documentation Code
if not get_option('tests').disabled()