summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build13
1 files changed, 11 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 540537d..9762339 100644
--- a/meson.build
+++ b/meson.build
@@ -471,9 +471,18 @@ if not get_option('tests').disabled()
cpp_test_args = []
if cpp.get_id() == 'clang'
- cpp_test_args = ['-Wall']
+ cpp_test_args = [
+ '-Wall',
+ '-Wno-nullability-extension',
+ '-Wno-padded',
+ '-Wno-zero-as-null-pointer-constant',
+ ]
elif cpp.get_id() == 'gcc'
- cpp_test_args = ['-Wall']
+ cpp_test_args = [
+ '-Wall',
+ '-Wno-padded',
+ '-Wno-unused-const-variable',
+ ]
elif cpp.get_id() == 'msvc'
cpp_test_args = ['/W3']
endif