summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 9 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 5d5eaa7..0e0afac 100644
--- a/meson.build
+++ b/meson.build
@@ -12,6 +12,7 @@ project('zix', ['c'],
'cpp_std=c++17',
])
+zix_src_root = meson.current_source_dir()
major_version = meson.project_version().split('.')[0]
version_suffix = '-@0@'.format(major_version)
versioned_name = 'zix' + version_suffix
@@ -521,8 +522,16 @@ if not get_option('benchmarks').disabled()
endif
endif
+#############################
+# Scripts and Documentation #
+#############################
+
subdir('scripts')
+if not get_option('docs').disabled()
+ subdir('doc')
+endif
+
if not meson.is_subproject()
summary('Benchmarks', build_benchmarks, bool_yn: true)
summary('Tests', not get_option('tests').disabled(), bool_yn: true)