summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 9 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index b6cbf02..68195bf 100644
--- a/meson.build
+++ b/meson.build
@@ -25,13 +25,21 @@ versioned_name = 'zix' + version_suffix
pkg = import('pkgconfig')
cc = meson.get_compiler('c')
+# Suppress unavoidable present even in default build
+c_warnings = []
+c_suppressions = []
+if cc.get_id() == 'clang'
+ c_warnings = [
+ '-Wno-nullability-extension',
+ ]
+endif
+
# Set ultra strict warnings for developers, if requested
if get_option('strict')
if cc.get_id() == 'clang'
c_warnings = [
'-Weverything',
'-Wno-bad-function-cast',
- '-Wno-nullability-extension',
'-Wno-padded',
'-Wno-reserved-id-macro',
]