summaryrefslogtreecommitdiffstats
path: root/meson/suppressions/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson/suppressions/meson.build')
-rw-r--r--meson/suppressions/meson.build16
1 files changed, 9 insertions, 7 deletions
diff --git a/meson/suppressions/meson.build b/meson/suppressions/meson.build
index d4abd30..24fa320 100644
--- a/meson/suppressions/meson.build
+++ b/meson/suppressions/meson.build
@@ -1,11 +1,9 @@
-# Copyright 2020-2022 David Robillard <d@drobilla.net>
+# Copyright 2020-2023 David Robillard <d@drobilla.net>
# SPDX-License-Identifier: 0BSD OR ISC
-# Project-specific warning suppressions.
-#
-# This should be used in conjunction with the generic "warnings" sibling that
-# enables all reasonable warnings for the compiler. It lives here just to keep
-# the top-level meson.build more readable.
+# Project-specific warning suppressions
+
+warning_level = get_option('warning_level')
#####
# C #
@@ -14,7 +12,7 @@
if is_variable('cc')
c_suppressions = []
- if get_option('strict')
+ if warning_level == 'everything'
if cc.get_id() in ['clang', 'emscripten']
c_suppressions += [
'-Wno-bad-function-cast',
@@ -81,6 +79,10 @@ if is_variable('cc')
]
elif cc.get_id() == 'msvc'
c_suppressions += [
+ '/experimental:external',
+ '/external:W0',
+ '/external:anglebrackets',
+
'/wd4706', # assignment within conditional expression
]
endif