summaryrefslogtreecommitdiffstats
path: root/meson/suppressions/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson/suppressions/meson.build')
-rw-r--r--meson/suppressions/meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson/suppressions/meson.build b/meson/suppressions/meson.build
index 06a0821..2f07e61 100644
--- a/meson/suppressions/meson.build
+++ b/meson/suppressions/meson.build
@@ -38,6 +38,7 @@ if is_variable('cc')
if host_machine.system() == 'windows'
c_suppressions += [
'-Wno-format',
+ '-Wno-suggest-attribute=const',
'-Wno-suggest-attribute=format',
'-Wno-suggest-attribute=pure',
]
@@ -56,6 +57,7 @@ if is_variable('cc')
'/wd4777', # format string and argument mismatch
'/wd4800', # implicit conversion to bool
'/wd4820', # padding added after construct
+ '/wd4996', # POSIX name for this item is deprecated
'/wd5045', # will insert Spectre mitigation for memory load
]
endif