summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2022-07-14 15:38:58 -0400
committerDavid Robillard <d@drobilla.net>2022-08-13 18:17:45 -0400
commitc83478ea0a19cc7fdf6e2cc228ed3697990732fe (patch)
treec6910dc1cc0b110d4f75d7e4dd918037687d3bb2 /meson.build
parent03b1626676f596d78df9de718e3e079e8269f5cc (diff)
downloadganv-c83478ea0a19cc7fdf6e2cc228ed3697990732fe.tar.gz
ganv-c83478ea0a19cc7fdf6e2cc228ed3697990732fe.tar.bz2
ganv-c83478ea0a19cc7fdf6e2cc228ed3697990732fe.zip
Move public headers to conventional include directory
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build50
1 files changed, 25 insertions, 25 deletions
diff --git a/meson.build b/meson.build
index c5dc4a6..1972e09 100644
--- a/meson.build
+++ b/meson.build
@@ -95,36 +95,36 @@ add_project_arguments(config_defines, language: ['c', 'cpp'])
# Library #
###########
-include_dirs = include_directories('.')
+include_dirs = include_directories('include')
c_headers = files(
- 'ganv/box.h',
- 'ganv/canvas.h',
- 'ganv/circle.h',
- 'ganv/edge.h',
- 'ganv/ganv.h',
- 'ganv/group.h',
- 'ganv/item.h',
- 'ganv/module.h',
- 'ganv/node.h',
- 'ganv/port.h',
- 'ganv/text.h',
- 'ganv/types.h',
- 'ganv/widget.h',
+ 'include/ganv/box.h',
+ 'include/ganv/canvas.h',
+ 'include/ganv/circle.h',
+ 'include/ganv/edge.h',
+ 'include/ganv/ganv.h',
+ 'include/ganv/group.h',
+ 'include/ganv/item.h',
+ 'include/ganv/module.h',
+ 'include/ganv/node.h',
+ 'include/ganv/port.h',
+ 'include/ganv/text.h',
+ 'include/ganv/types.h',
+ 'include/ganv/widget.h',
)
cpp_headers = files(
- 'ganv/Box.hpp',
- 'ganv/Canvas.hpp',
- 'ganv/Circle.hpp',
- 'ganv/Edge.hpp',
- 'ganv/Item.hpp',
- 'ganv/Module.hpp',
- 'ganv/Node.hpp',
- 'ganv/Port.hpp',
- 'ganv/ganv.hpp',
- 'ganv/types.hpp',
- 'ganv/wrap.hpp',
+ 'include/ganv/Box.hpp',
+ 'include/ganv/Canvas.hpp',
+ 'include/ganv/Circle.hpp',
+ 'include/ganv/Edge.hpp',
+ 'include/ganv/Item.hpp',
+ 'include/ganv/Module.hpp',
+ 'include/ganv/Node.hpp',
+ 'include/ganv/Port.hpp',
+ 'include/ganv/ganv.hpp',
+ 'include/ganv/types.hpp',
+ 'include/ganv/wrap.hpp',
)
sources = files(