summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Schleef <ds@schleef.org>2004-05-11 02:30:16 +0000
committerDavid Schleef <ds@schleef.org>2004-05-11 02:30:16 +0000
commit08499d6af30a23913cd46d2c4e52edfc3fa766b4 (patch)
tree6213ecb62f3967c90566aafd68e6731c6a1cc951 /configure.ac
parentac2b21a7c624ef34ad92befa08325c76f2f7d5a7 (diff)
downloadgst-plugins-bad-08499d6af30a23913cd46d2c4e52edfc3fa766b4.tar.gz
gst-plugins-bad-08499d6af30a23913cd46d2c4e52edfc3fa766b4.tar.bz2
gst-plugins-bad-08499d6af30a23913cd46d2c4e52edfc3fa766b4.zip
configure.ac: Add prototype Dirac support.
Original commit message from CVS: * configure.ac: Add prototype Dirac support. * ext/Makefile.am: * ext/dirac/Makefile.am: * ext/dirac/gstdirac.cc: * ext/dirac/gstdiracdec.cc:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 10 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 7027639d..d904f932 100644
--- a/configure.ac
+++ b/configure.ac
@@ -329,7 +329,7 @@ dnl ===========================================================================
plugindir="\$(libdir)/gstreamer-$GST_MAJORMINOR"
AC_SUBST(plugindir)
-GST_PLUGIN_LDFLAGS='-module -avoid-version -export-symbols-regex [_]*\(gst_\|Gst\|GST_\).*'
+GST_PLUGIN_LDFLAGS="-module -avoid-version -export-symbols-regex '[_]*(gst_|Gst|GST_).*' $GST_LIBS"
AC_SUBST(GST_PLUGIN_LDFLAGS)
dnl these are all the gst plug-ins, compilable without additional libs
@@ -751,6 +751,14 @@ dnl FIXME : add second check somehow if that is necessary
dnl AC_CHECK_LIB(cdda_paranoia, paranoia_init, : , HAVE_CDPARANOIA=no, -lcdda_interface )
dnl AC_CHECK_HEADER(cdda_paranoia.h, :, HAVE_CDPARANOIA=no)
+dnl *** dirac ***
+translit(dnm, m, l) AM_CONDITIONAL(USE_DIRAC, true)
+GST_CHECK_FEATURE(DIRAC, [dirac plug-ins], dirac, [
+ PKG_CHECK_MODULES(DIRAC, dirac, HAVE_DIRAC="yes", HAVE_DIRAC="no")
+ AC_SUBST(DIRAC_CFLAGS)
+ AC_SUBST(DIRAC_LIBS)
+])
+
dnl *** DIVX ***
translit(dnm, m, l) AM_CONDITIONAL(USE_DIVX, true)
GST_CHECK_FEATURE(DIVX, [divx plugins], divx, [
@@ -1793,6 +1801,7 @@ ext/arts/Makefile
ext/artsd/Makefile
ext/audiofile/Makefile
ext/cdparanoia/Makefile
+ext/dirac/Makefile
ext/divx/Makefile
ext/dts/Makefile
ext/dv/Makefile