summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Smith <msmith@xiph.org>2006-03-31 14:26:05 +0000
committerMichael Smith <msmith@xiph.org>2006-03-31 14:26:05 +0000
commit15d5008ffc61e32156316ebedb1a1fb5bf7a683f (patch)
treea65338fb184996cafa5f35097ba9eb7a48cf2ff7 /configure.ac
parentde433bfdcb5ba523f6e0c5ec0589f5bd890cee35 (diff)
downloadgst-plugins-bad-15d5008ffc61e32156316ebedb1a1fb5bf7a683f.tar.gz
gst-plugins-bad-15d5008ffc61e32156316ebedb1a1fb5bf7a683f.tar.bz2
gst-plugins-bad-15d5008ffc61e32156316ebedb1a1fb5bf7a683f.zip
configure.ac: Add autoconfery for theoradec.
Original commit message from CVS: * configure.ac: Add autoconfery for theoradec. * ext/Makefile.am: Add theora directory. * ext/theora/Makefile.am: * ext/theora/theoradec.c: (gst_theoradec_base_init), (gst_theoradec_class_init), (gst_theoradec_init), (gst_theoradec_reset), (inc_granulepos), (theora_get_query_types), (gst_theoradec_granule_clocktime), (theora_dec_src_convert), (theora_dec_sink_convert), (theora_dec_src_query), (theora_dec_sink_query), (theora_dec_src_event), (theora_dec_sink_event), (theora_handle_comment_packet), (theora_handle_type_packet), (theora_handle_header_packet), (theora_dec_push), (theora_handle_data_packet), (theora_dec_chain), (theora_dec_change_state), (plugin_init): * ext/theora/theoradec.h: Add theora plugin for theora-exp decoder. Very heavily based on the existing theora decoder plugin.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a8af49f5..bea5b9cc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -706,6 +706,14 @@ GST_CHECK_FEATURE(XVIDEO, [X11 XVideo extensions],
fi
])
+dnl *** theora ***
+translit(dnm, m, l) AM_CONDITIONAL(USE_THEORADEC, true)
+GST_CHECK_FEATURE(THEORADEC, [ogg theora codec], theoradec, [
+ PKG_CHECK_MODULES(THEORADEC, theoradec, HAVE_THEORADEC="yes", HAVE_THEORADEC="no")
+ AC_SUBST(THEORADEC_LIBS)
+ AC_SUBST(THEORADEC_CFLAGS)
+])
+
dnl *** Video 4 Linux 2 ***
dnl for information about the header/define, see sys/v4l2/gstv4l2element.h
dnl renamed to GST_V4L2 because of some conflict with kernel headers
@@ -853,6 +861,7 @@ ext/musepack/Makefile
ext/sdl/Makefile
ext/swfdec/Makefile
ext/taglib/Makefile
+ext/theora/Makefile
ext/xvid/Makefile
docs/Makefile
docs/plugins/Makefile