summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRonald S. Bultje <rbultje@ronald.bitfreak.net>2005-03-09 12:06:56 +0000
committerRonald S. Bultje <rbultje@ronald.bitfreak.net>2005-03-09 12:06:56 +0000
commit1c37934861f2dd7c3ca38fe770734e2b3b30cfdb (patch)
treee35e4d8254b1708b6a469ff2ee6c71c3de83f1b5 /configure.ac
parentdb69a0a5961f3b044d643ff476c97a92407e2b89 (diff)
downloadgst-plugins-bad-1c37934861f2dd7c3ca38fe770734e2b3b30cfdb.tar.gz
gst-plugins-bad-1c37934861f2dd7c3ca38fe770734e2b3b30cfdb.tar.bz2
gst-plugins-bad-1c37934861f2dd7c3ca38fe770734e2b3b30cfdb.zip
configure.ac: Fix FAAD detection problems against FAAD-CVS.
Original commit message from CVS: * configure.ac: Fix FAAD detection problems against FAAD-CVS. * ext/faad/gstfaad.c: (gst_faad_class_init), (gst_faad_chanpos_to_gst), (gst_faad_srcconnect), (gst_faad_sync), (gst_faad_chain): Fix FAAD channel positions for mono/stereo against FAAD CVS. Implement raw stream sync support for AAC+ radio support. Embed info structure in our function to prevent unneeded excessive allocations. * ext/ogg/gstoggdemux.c: (gst_ogg_pad_populate), (gst_ogg_demux_push): Only set first/last positions when we search for them. Fixes invalid length reporting for some video files. * gst/playback/gstdecodebin.c: (remove_element_chain): Always remove only our own kids. * gst/qtdemux/qtdemux.c: (qtdemux_parse), (qtdemux_parse_trak): Fix ESDS atom finding bug. * gst/typefind/gsttypefindfunctions.c: (aac_type_find): Implement frame-finding (similar to MP3) to support AAC+ radio.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 9214de1d..f32dce0b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1033,7 +1033,10 @@ dnl **** Free AAC Decoder (FAAD) ****
translit(dnm, m, l) AM_CONDITIONAL(USE_FAAD, true)
GST_CHECK_FEATURE(FAAD, [AAC decoder plug-in], faad, [
HAVE_FAAD="yes"
- GST_CHECK_LIBHEADER(FAAD, faad, faacDecOpen, -lm, faad.h, FAAD_LIBS="-lfaad -lm", HAVE_FAAD="no")
+ FAAD_LIBS="-lfaad -lm"
+ GST_CHECK_LIBHEADER(FAAD, faad, faacDecOpen, -lm, faad.h, , [
+ GST_CHECK_LIBHEADER(FAAD, faad, NeAACDecOpen, -lm, faad.h, , HAVE_FAAD="no")
+ ])
if test $HAVE_FAAD = "yes"; then
AC_MSG_CHECKING([Checking for FAAD >= 2])
AC_TRY_RUN([