summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDamien Lespiau <damien.lespiau@gmail.com>2008-07-04 16:06:09 +0000
committerSebastian Dröge <slomo@circular-chaos.org>2008-07-04 16:06:09 +0000
commit1f25b18c45770894988fa8914e6cd905c4f81fa3 (patch)
treec4b79236648e0aaf1e2f898ee6fb2a6ab63a3097 /configure.ac
parent4e2dcf4015d952f8311a019f06fc85765089886b (diff)
downloadgst-plugins-bad-1f25b18c45770894988fa8914e6cd905c4f81fa3.tar.gz
gst-plugins-bad-1f25b18c45770894988fa8914e6cd905c4f81fa3.tar.bz2
gst-plugins-bad-1f25b18c45770894988fa8914e6cd905c4f81fa3.zip
Fix built of the festival plugin with mingw32 by linking to ws2_32.dll and including winsock headers. Fixes bug #541522.
Original commit message from CVS: Patch by: Damien Lespiau <damien dot lespiau at gmail dot com> * configure.ac: * gst/festival/Makefile.am: * gst/festival/gstfestival.c: Fix built of the festival plugin with mingw32 by linking to ws2_32.dll and including winsock headers. Fixes bug #541522.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c6cf3527..ab215942 100644
--- a/configure.ac
+++ b/configure.ac
@@ -303,6 +303,9 @@ dnl FIXME: maybe move to sys, or make work with winsock2
AC_CHECK_HEADERS([sys/socket.h], HAVE_SYS_SOCKET_H=yes)
AC_CHECK_HEADERS([winsock2.h], HAVE_WINSOCK2_H=yes)
+dnl needed for festival
+AM_CONDITIONAL(HAVE_WINSOCK2_H, test "x$HAVE_WINSOCK2_H" = "xyes")
+
if test "x$HAVE_SYS_SOCKET_H" != "xyes"; then
AG_GST_DISABLE_PLUGIN(librfb)
fi