summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAndy Wingo <wingo@oblong.net>2009-04-20 13:09:46 +0200
committerDave Robillard <dave@drobilla.net>2009-05-03 12:03:16 -0400
commit20ab17aa249366a97109b8110bf78cd7431e078a (patch)
treeaf9ec89107bb18fbb8a0e7f51d53e350961fe7d0 /configure.ac
parent3febe4460a6618cee9a32cbfa5661f81a720f38e (diff)
downloadgst-plugins-bad-20ab17aa249366a97109b8110bf78cd7431e078a.tar.gz
gst-plugins-bad-20ab17aa249366a97109b8110bf78cd7431e078a.tar.bz2
gst-plugins-bad-20ab17aa249366a97109b8110bf78cd7431e078a.zip
add osxvideosrc
* configure.ac: * sys/Makefile.am: * sys/osxvideo/Makefile.am: Autoconfiscation. * sys/osxvideo/osxvideoplugin.m: * sys/osxvideo/osxvideosrc.h: * sys/osxvideo/osxvideosrc.c: Add osxvideosrc. Should fix #153684. Patch-by: Ole André Vadla Ravnås <ole.andre.ravnas@tandberg.com> Patch-by: Ali Sabil <ali.sabil@tandberg.com> Patch-by: Barracuda Networks <justin@affinix.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8ed46b4d..0e251c1c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -359,6 +359,22 @@ fi
dnl *** sys plug-ins ***
+dnl *** OS X videosrc ***
+translit(dnm, m, l) AM_CONDITIONAL(USE_OSX_VIDEO, true)
+HAVE_OSX_VIDEO="no"
+AG_GST_CHECK_FEATURE(OSX_VIDEO, [OSX video], osxvideosrc, [
+ AC_CHECK_HEADER(Quicktime/Quicktime.h, HAVE_OSX_VIDEO="yes", HAVE_OSX_VIDEO="no")
+])
+dnl in case header Quicktime/Quicktime.h is found on other platforms
+case "$host" in
+ *-*darwin*)
+ dnl do nothing
+ ;;
+ *)
+ HAVE_OSX_VIDEO="no"
+ ;;
+esac
+
dnl check for QuickTime
translit(dnm, m, l) AM_CONDITIONAL(USE_QUICKTIME, true)
AG_GST_CHECK_FEATURE(QUICKTIME, [QuickTime wrapper], qtwrapper, [
@@ -1574,6 +1590,7 @@ sys/dshowvideosink/Makefile
sys/dvb/Makefile
sys/fbdev/Makefile
sys/oss4/Makefile
+sys/osxvideo/Makefile
sys/qtwrapper/Makefile
sys/vcd/Makefile
sys/wasapi/Makefile