summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Vander Stichele <thomas@apestaart.org>2004-08-30 10:03:18 +0000
committerThomas Vander Stichele <thomas@apestaart.org>2004-08-30 10:03:18 +0000
commit22e8e61f2a54d8b7a15f093c563263bbab1ac496 (patch)
treeadfba39e94b182b961ca1d9a29765ebb53e05063 /configure.ac
parentbeda3915798a9efbef0f0613479de7f8abe2718b (diff)
downloadgst-plugins-bad-22e8e61f2a54d8b7a15f093c563263bbab1ac496.tar.gz
gst-plugins-bad-22e8e61f2a54d8b7a15f093c563263bbab1ac496.tar.bz2
gst-plugins-bad-22e8e61f2a54d8b7a15f093c563263bbab1ac496.zip
fixes #151232
Original commit message from CVS: fixes #151232
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 0bda1cce..1a5ff31a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1197,7 +1197,14 @@ GST_CHECK_FEATURE(LAME, [lame mp3 encoder library], lame, [
])
dnl is lame presets available
LAME_CFLAGS=""
-GST_CHECK_LIBHEADER(GSTLAME_PRESET, mp3lame, lame_set_preset, -lm, lame/lame.h, LAME_CFLAGS="-DGSTLAME_PRESET", LAME_CFLAGS="")
+AC_TRY_RUN([
+#include <lame/lame.h>
+int main (int argc, char *argv[])
+{
+ printf("%d\n", MEDIUM);
+ return 0;
+}
+],[LAME_CFLAGS="-DGSTLAME_PRESET"],[LAME_CFLAGS=""])
AC_SUBST(LAME_CFLAGS)
AC_SUBST(LAME_LIBS)