summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Vander Stichele <thomas@apestaart.org>2004-10-04 15:11:49 +0000
committerThomas Vander Stichele <thomas@apestaart.org>2004-10-04 15:11:49 +0000
commit351a87672cdd68520a13a32df07f68a255126758 (patch)
tree99a2fbacbac5c6056abe33a8c08d2879a5060fee /configure.ac
parentdf1685e907bcd5528c75e350a98ae4c329ea9b56 (diff)
downloadgst-plugins-bad-351a87672cdd68520a13a32df07f68a255126758.tar.gz
gst-plugins-bad-351a87672cdd68520a13a32df07f68a255126758.tar.bz2
gst-plugins-bad-351a87672cdd68520a13a32df07f68a255126758.zip
you need 1.0.4 of speex
Original commit message from CVS: you need 1.0.4 of speex
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 11 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index cba07ad1..270d67e5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1432,7 +1432,7 @@ GST_CHECK_FEATURE(LIBPNG, [snapshot plug-in], snapshot, [
AC_SUBST(LIBPNG_LIBS)
])
-dnl *** speex 1.0.x or >= 1.1.5 ***
+dnl *** speex >= 1.0.4 or >= 1.1.5 ***
dnl 1.1.4 and earlier were not API/ABI compatible with 1.0
dnl 1.1.6 is the first to use a .pc/pkg-config file ***
dnl speex_jitter.h is 1.1.x only
@@ -1455,12 +1455,17 @@ GST_CHECK_FEATURE(SPEEX, [speex plug-in], speex, [
],[
HAVE_SPEEX="no"
])
- ], [
+ ],[
dnl speex 1.0.x :
- HAVE_SPEEX="yes"
- SPEEX_LIBS="-lspeex"
- AC_SUBST(SPEEX_CFLAGS)
- AC_SUBST(SPEEX_LIBS)
+ AC_CHECK_DECL(SPEEX_GET_LOOKAHEAD, [
+ dnl speex 1.0.4
+ HAVE_SPEEX="yes"
+ SPEEX_LIBS="-lspeex"
+ AC_SUBST(SPEEX_CFLAGS)
+ AC_SUBST(SPEEX_LIBS)
+ ],[
+ AC_MSG_NOTICE(You need at least 1.0.4 to compile the speex plugin)
+ ])
])
])
])