summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorBrian Cameron <brian.cameron@sun.com>2009-01-23 10:11:52 +0100
committerSebastian Dröge <slomo@circular-chaos.org>2009-01-23 10:11:52 +0100
commit486d76b4544ee9d2c4cf6ab5730f0f12c422a6d0 (patch)
treead47dacf5b2d0a55a17008159d33a93a2cc2c505 /configure.ac
parent7ce5b5a2d66feefd101a35ea0e9beae7c1643158 (diff)
downloadgst-plugins-bad-486d76b4544ee9d2c4cf6ab5730f0f12c422a6d0.tar.gz
gst-plugins-bad-486d76b4544ee9d2c4cf6ab5730f0f12c422a6d0.tar.bz2
gst-plugins-bad-486d76b4544ee9d2c4cf6ab5730f0f12c422a6d0.zip
Fix build on Solaris. Fixes bug #568480.
Fix linking on Solaris by checking for the nsl and socket libraries which are needed for socket() and gethostbyname(). Don't initialize some fields of struct mh to NULL/0, they're already set to NULL/0 by a memset(). Also this fields don't exist on Solaris.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e31a119f..167953bf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -157,6 +157,10 @@ dnl *** checks for library functions ***
dnl *** checks for dependency libraries ***
+dnl *** checks for socket and nsl libraries ***
+AC_CHECK_FUNC(socket,,[AC_CHECK_LIB(socket,socket)])
+AC_CHECK_FUNC(gethostbyname,,[AC_CHECK_LIB(nsl,gethostbyname)])
+
dnl GLib is required
AG_GST_GLIB_CHECK([2.6])