summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorBrian Cameron <brian.cameron@sun.com>2003-05-21 18:16:30 +0000
committerBrian Cameron <brian.cameron@sun.com>2003-05-21 18:16:30 +0000
commit4c3c8f6f108d324168058af3100d013497184956 (patch)
tree7c06fc306c4fd97efea17de75bbb0e4b494e5753 /configure.ac
parenta62ca0048edd89cff24bc4550b456cf875bc5439 (diff)
downloadgst-plugins-bad-4c3c8f6f108d324168058af3100d013497184956.tar.gz
gst-plugins-bad-4c3c8f6f108d324168058af3100d013497184956.tar.bz2
gst-plugins-bad-4c3c8f6f108d324168058af3100d013497184956.zip
Corrected the configure.ac so it actually works. Updated some c files so that they build on Solaris. This mostly in...
Original commit message from CVS: Corrected the configure.ac so it actually works. Updated some c files so that they build on Solaris. This mostly involved supporting ISO style variable-argument macros.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 15 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index b9c0bb0b..ba930d49 100644
--- a/configure.ac
+++ b/configure.ac
@@ -41,17 +41,21 @@ AM_PROG_AS
AS="${CC}"
dnl decide on error flags
-AS_COMPILER_FLAG(-Wall,GST_ERROR="$GST_ERROR -Wall",GST_ERROR="$GST_ERROR")
-if test "x$GST_CVS"="xyes"; then
- AS_COMPILER_FLAG(-Werror,GST_ERROR="$GST_ERROR -Werror",GST_ERROR="$GST_ERROR")
-
- # Only set these optimization flags if gcc is being used.
- #
- GST_FUNROLL_CFLAGS="$GST_FUNROLL_CFLAGS -funroll-all-loops"
- GST_FINLINE_CFLAGS="$GST_FINLINE_CFLAGS -finline-functions"
- GST_FFASTMATH_CFLAGS="$GST_FFASTMATH_CFLAGS -ffast-math"
- GST_FSCHEDULE_CFLAGS="$GST_FSCHEDULE_CFLAGS -fschedule-insns2"
- GST_FNOEXCEPTIONS_CFLAGS="$GST_FNOEXCEPTIONS_CFLAGS -fno-exceptions"
+AS_COMPILER_FLAG(-Wall, GST_WALL="yes", GST_WALL="no")
+
+if test "x$GST_WALL" = "xyes"; then
+ GST_ERROR="$GST_ERROR -Wall"
+
+ if test "x$GST_CVS" = "xyes"; then
+ AS_COMPILER_FLAG(-Werror,GST_ERROR="$GST_ERROR -Werror",GST_ERROR="$GST_ERROR")
+ fi
+
+ dnl set gcc-style optimization flags if using the gnu compiler.
+ GST_FUNROLL_CFLAGS="$GST_FUNROLL_CFLAGS -funroll-all-loops"
+ GST_FINLINE_CFLAGS="$GST_FINLINE_CFLAGS -finline-functions"
+ GST_FFASTMATH_CFLAGS="$GST_FFASTMATH_CFLAGS -ffast-math"
+ GST_FSCHEDULE_CFLAGS="$GST_FSCHEDULE_CFLAGS -fschedule-insns2"
+ GST_FNOEXCEPTIONS_CFLAGS="$GST_FNOEXCEPTIONS_CFLAGS -fno-exceptions"
fi
dnl determine c++ compiler