summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorWim Taymans <wim.taymans@gmail.com>2005-05-06 17:24:44 +0000
committerWim Taymans <wim.taymans@gmail.com>2005-05-06 17:24:44 +0000
commit4d3647265634c63bfb1f901c4c3d537e6a342816 (patch)
tree2a18734a0aaa0d6d251ed24547033116c26676a7 /configure.ac
parent70a18353834f2d4d845ec92899b6534beb12308a (diff)
downloadgst-plugins-bad-4d3647265634c63bfb1f901c4c3d537e6a342816.tar.gz
gst-plugins-bad-4d3647265634c63bfb1f901c4c3d537e6a342816.tar.bz2
gst-plugins-bad-4d3647265634c63bfb1f901c4c3d537e6a342816.zip
Ported sidplay.
Original commit message from CVS: * configure.ac: * ext/sidplay/gstsiddec.cc: * ext/sidplay/gstsiddec.h: Ported sidplay.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index cac2e305..9ce7b321 100644
--- a/configure.ac
+++ b/configure.ac
@@ -295,7 +295,8 @@ dnl these are all the gst plug-ins, compilable without additional libs
GST_PLUGINS_ALL="\
videofilter \
effectv \
- law"
+ law \
+ sidplay"
dnl see if we can build C++ plug-ins
if test "x$HAVE_CXX" = "xyes"; then
@@ -348,6 +349,12 @@ dnl ])
dnl ])
dnl ])
+dnl *** sidplay : works with libsidplay 1.36.x (not 2.x.x) ***
+translit(dnm, m, l) AM_CONDITIONAL(USE_SIDPLAY, true)
+GST_CHECK_FEATURE(SIDPLAY, [sidplay plug-in], sidplay, [
+ GST_PATH_SIDPLAY()
+ ])
+
dnl *** mad ***
dnl FIXME: we could use header checks here as well IMO
translit(dnm, m, l) AM_CONDITIONAL(USE_MAD, true)
@@ -431,6 +438,7 @@ gst/videofilter/Makefile
sys/Makefile
ext/Makefile
ext/mad/Makefile
+ext/sidplay/Makefile
common/Makefile
common/m4/Makefile
m4/Makefile