summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorStéphane Loeuillet <gstreamer@leroutier.net>2005-01-05 23:38:23 +0000
committerStéphane Loeuillet <gstreamer@leroutier.net>2005-01-05 23:38:23 +0000
commit5f54ebdc1f14046bdb117639bfe1210048ad78cd (patch)
treee6539881a526a661135ee71d2b87f2231f1fa454 /configure.ac
parent563144ad3a53d1428848cef045901d0278d59572 (diff)
downloadgst-plugins-bad-5f54ebdc1f14046bdb117639bfe1210048ad78cd.tar.gz
gst-plugins-bad-5f54ebdc1f14046bdb117639bfe1210048ad78cd.tar.bz2
gst-plugins-bad-5f54ebdc1f14046bdb117639bfe1210048ad78cd.zip
configure.ac: don't compile faad plugin if a RC of 2.0 is found
Original commit message from CVS: * configure.ac: don't compile faad plugin if a RC of 2.0 is found * gst/asfdemux/gstasfdemux.c: (gst_asf_demux_process_ext_content_desc): try to make Solaris compiler happier
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 15 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 5809d930..b27d373f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1015,12 +1015,25 @@ GST_CHECK_FEATURE(FAAD, [AAC decoder plug-in], faad, [
GST_CHECK_LIBHEADER(FAAD, faad, faacDecOpen, -lm, faad.h, FAAD_LIBS="-lfaad -lm", HAVE_FAAD="no")
if test $HAVE_FAAD = "yes"; then
AC_MSG_CHECKING([Checking for FAAD >= 2])
- AC_TRY_COMPILE([
+ AC_TRY_RUN([
+
#include <faad.h>
#if !defined(FAAD2_VERSION) || !defined(FAAD_FMT_DOUBLE)
#error Not faad2
+#else
+#include <string.h>
+
+int main()
+{
+char version[9] = FAAD2_VERSION;
+// a release candidate of 2.0 is not enought for us
+if ( strstr( version, "2.0 RC" ) ) { return 1; }
+
+return 0;
+}
+
#endif
- ], [ return 0; ],
+ ],
[ HAVE_FAAD="yes" && AC_MSG_RESULT(yes)],
[ HAVE_FAAD="no" && AC_MSG_RESULT(no)])
fi;