summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Schleef <ds@schleef.org>2004-01-12 03:37:48 +0000
committerDavid Schleef <ds@schleef.org>2004-01-12 03:37:48 +0000
commit60809db458162408f0effa28c5819800c78ed90d (patch)
treeca11052ff010a2130aea2704280115765afa4f43 /configure.ac
parent538adea7fa1756c41e55c3b3e7f4bc9f6d206cfc (diff)
downloadgst-plugins-bad-60809db458162408f0effa28c5819800c78ed90d.tar.gz
gst-plugins-bad-60809db458162408f0effa28c5819800c78ed90d.tar.bz2
gst-plugins-bad-60809db458162408f0effa28c5819800c78ed90d.zip
Fixes to make ext/libcaca compile.
Original commit message from CVS: * configure.ac: * ext/Makefile.am: Fixes to make ext/libcaca compile.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2753b76d..51da5521 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1021,6 +1021,14 @@ GST_CHECK_FEATURE(LIBDV, [libdv DV/video decoder], dvdec, [
AC_SUBST(LIBDV_LIBS)
])
+dnl *** libcaca ***
+translit(dnm, m, l) AM_CONDITIONAL(USE_LIBCACA, true)
+GST_CHECK_FEATURE(LIBCACA, [libcaca], libcaca, [
+ GST_CHECK_CONFIGPROG(LIBCACA, caca-config)
+ AC_SUBST(LIBCACA_CFLAGS)
+ AC_SUBST(LIBCACA_LIBS)
+])
+
dnl *** libfame ***
translit(dnm, m, l) AM_CONDITIONAL(USE_LIBFAME, true)
GST_CHECK_FEATURE(LIBFAME, [libfame MPEG1/4 encoder], libfame, [
@@ -1614,6 +1622,7 @@ ext/ladspa/Makefile
ext/lame/Makefile
ext/ivorbis/Makefile
ext/lcs/Makefile
+ext/libcaca/Makefile
ext/libfame/Makefile
ext/libpng/Makefile
ext/librfb/Makefile