summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Smith <msmith@songbirdnest.com>2009-04-08 11:52:46 -0700
committerDave Robillard <dave@drobilla.net>2009-05-03 12:03:14 -0400
commit6225d5a6bdf22ff968171d5c8b450a6afd7a8eb0 (patch)
tree440bba54195c83ae3dd0c89f6f58f31ab7fd0420 /configure.ac
parentb8de3969acdb19bcb68738d512c6ef29a1646a73 (diff)
downloadgst-plugins-bad-6225d5a6bdf22ff968171d5c8b450a6afd7a8eb0.tar.gz
gst-plugins-bad-6225d5a6bdf22ff968171d5c8b450a6afd7a8eb0.tar.bz2
gst-plugins-bad-6225d5a6bdf22ff968171d5c8b450a6afd7a8eb0.zip
acmenc, acmmp3dec, sdp: link to all requires libraries on win32.
Add winsock for windows (for sdp). Link to all the plugins-base libs we indirectly use for acmmenc and acmmp3dec.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c6629258..4d448e45 100644
--- a/configure.ac
+++ b/configure.ac
@@ -328,6 +328,11 @@ dnl FIXME: maybe move to sys, or make work with winsock2
AC_CHECK_HEADERS([sys/socket.h], HAVE_SYS_SOCKET_H=yes)
AC_CHECK_HEADERS([winsock2.h], HAVE_WINSOCK2_H=yes)
+if test "x$HAVE_WINSOCK2_H" = "xyes"; then
+ WIN32_LIBS="-lws2_32"
+ AC_SUBST(WIN32_LIBS)
+fi
+
dnl needed for festival
AM_CONDITIONAL(HAVE_WINSOCK2_H, test "x$HAVE_WINSOCK2_H" = "xyes")