summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorStéphane Loeuillet <gstreamer@leroutier.net>2004-05-20 21:57:11 +0000
committerStéphane Loeuillet <gstreamer@leroutier.net>2004-05-20 21:57:11 +0000
commit63e298e2f4a7631a70c9eb403891408867a16e73 (patch)
tree66e1f8d1a98e48ee808703f764320b375987197c /configure.ac
parent8927ae0f8eab89c9361e0d9b5898f05a3775a1c4 (diff)
downloadgst-plugins-bad-63e298e2f4a7631a70c9eb403891408867a16e73.tar.gz
gst-plugins-bad-63e298e2f4a7631a70c9eb403891408867a16e73.tar.bz2
gst-plugins-bad-63e298e2f4a7631a70c9eb403891408867a16e73.zip
- reenable speex plugins for speex 1.1.5 (API/ABI compatible with 1.0.x)
Original commit message from CVS: - reenable speex plugins for speex 1.1.5 (API/ABI compatible with 1.0.x) - fix a cast warning that prevent compilation of speexenc
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 14 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index eba293a8..b242d44d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1425,12 +1425,24 @@ GST_CHECK_FEATURE(LIBPNG, [snapshot plug-in], snapshot, [
AC_SUBST(LIBPNG_LIBS)
])
-dnl *** speex 1.0 only, not 1.1 ***
+dnl *** speex 1.0.x or >= 1.1.5 (1.1.4 and earlier were not API/ABI compatible ***
dnl speex_jitter.h is 1.1 only
translit(dnm, m, l) AM_CONDITIONAL(USE_SPEEX, true)
GST_CHECK_FEATURE(SPEEX, [speex plug-in], speex, [
GST_CHECK_LIBHEADER(SPEEX, speex, speex_bits_init, , speex.h, [
- AC_CHECK_HEADER(speex_jitter.h, HAVE_SPEEX="no", [
+ AC_CHECK_HEADER(speex_jitter.h, [
+ dnl speex 1.1.x :
+ GST_CHECK_LIBHEADER(SPEEX, speex, speex_encode_int, , speex.h, [
+ dnl speex 1.1.5 or + :
+ HAVE_SPEEX="yes"
+ SPEEX_LIBS="-lspeex"
+ AC_SUBST(SPEEX_CFLAGS)
+ AC_SUBST(SPEEX_LIBS)
+ ],[
+ HAVE_SPEEX="no"
+ ])
+ ], [
+ dnl speex 1.0.x :
HAVE_SPEEX="yes"
SPEEX_LIBS="-lspeex"
AC_SUBST(SPEEX_CFLAGS)