summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorSebastian Dröge <slomo@circular-chaos.org>2007-11-20 07:02:45 +0000
committerSebastian Dröge <slomo@circular-chaos.org>2007-11-20 07:02:45 +0000
commit644432907c659f4fdc64bef9cf13d54f6e30b60c (patch)
tree16191518dd33b15232d7a44526063fbbc92f2326 /configure.ac
parentac04e0124b18beb8fa0240479d284ec6383ebcc0 (diff)
downloadgst-plugins-bad-644432907c659f4fdc64bef9cf13d54f6e30b60c.tar.gz
gst-plugins-bad-644432907c659f4fdc64bef9cf13d54f6e30b60c.tar.bz2
gst-plugins-bad-644432907c659f4fdc64bef9cf13d54f6e30b60c.zip
Add resample element based on the Speex resampling algorithm.
Original commit message from CVS: * configure.ac: * gst/speexresample/arch.h: * gst/speexresample/fixed_generic.h: * gst/speexresample/gstspeexresample.c: (gst_speex_resample_base_init), (gst_speex_resample_class_init), (gst_speex_resample_init), (gst_speex_resample_start), (gst_speex_resample_stop), (gst_speex_resample_get_unit_size), (gst_speex_resample_transform_caps), (gst_speex_resample_init_state), (gst_speex_resample_update_state), (gst_speex_resample_reset_state), (gst_speex_resample_parse_caps), (gst_speex_resample_transform_size), (gst_speex_resample_set_caps), (gst_speex_resample_event), (gst_speex_resample_check_discont), (gst_speex_resample_process), (gst_speex_resample_transform), (gst_speex_resample_set_property), (gst_speex_resample_get_property), (plugin_init): * gst/speexresample/gstspeexresample.h: * gst/speexresample/resample.c: (speex_alloc), (speex_realloc), (speex_free), (compute_func), (main), (sinc), (cubic_coef), (resampler_basic_direct_single), (resampler_basic_direct_double), (resampler_basic_interpolate_single), (resampler_basic_interpolate_double), (update_filter), (speex_resampler_init), (speex_resampler_init_frac), (speex_resampler_destroy), (speex_resampler_process_native), (speex_resampler_process_float), (speex_resampler_process_int), (speex_resampler_process_interleaved_float), (speex_resampler_process_interleaved_int), (speex_resampler_set_rate), (speex_resampler_get_rate), (speex_resampler_set_rate_frac), (speex_resampler_get_ratio), (speex_resampler_set_quality), (speex_resampler_get_quality), (speex_resampler_set_input_stride), (speex_resampler_get_input_stride), (speex_resampler_set_output_stride), (speex_resampler_get_output_stride), (speex_resampler_skip_zeros), (speex_resampler_reset_mem), (speex_resampler_strerror): * gst/speexresample/speex_resampler.h: * gst/speexresample/speex_resampler_float.c: * gst/speexresample/speex_resampler_int.c: * gst/speexresample/speex_resampler_wrapper.h: Add resample element based on the Speex resampling algorithm.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b6ab0cf7..dcf4b35d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -105,6 +105,7 @@ GST_PLUGINS_ALL="\
rtpmanager \
sdp \
spectrum \
+ speexresample \
speed \
stereo \
switch \
@@ -1069,6 +1070,7 @@ gst/rtpmanager/Makefile
gst/sdp/Makefile
gst/spectrum/Makefile
gst/speed/Makefile
+gst/speexresample/Makefile
gst/stereo/Makefile
gst/switch/Makefile
gst/tta/Makefile