summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDave Robillard <dave@drobilla.net>2009-06-22 17:04:22 -0400
committerDave Robillard <dave@drobilla.net>2009-06-22 17:04:22 -0400
commit7a7083ba1f8e38b0b51820d4a37f279c6b2c73bd (patch)
tree5fb2f44346d722fa2c707854a187cb2ab8dff1af /configure.ac
parenta6389f9a9220e11110778ec46b6c12abeb058d94 (diff)
parent218878de5ea48b5acdf36070a73a50fd71f41741 (diff)
downloadgst-plugins-bad-7a7083ba1f8e38b0b51820d4a37f279c6b2c73bd.tar.gz
gst-plugins-bad-7a7083ba1f8e38b0b51820d4a37f279c6b2c73bd.tar.bz2
gst-plugins-bad-7a7083ba1f8e38b0b51820d4a37f279c6b2c73bd.zip
Merge branch 'fdo' into lv2
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac65
1 files changed, 53 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index 7cc268ad..ac22aef5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1430,6 +1430,44 @@ AG_GST_CHECK_FEATURE(ACM, [Windows ACM library], acm, [
], [HAVE_ACM="no"])
])
+dnl *** vdpau ***
+translit(dnm, m, l) AM_CONDITIONAL(USE_VDPAU, true)
+AG_GST_CHECK_FEATURE(VDPAU, [VDPAU], vdpau, [
+ VDPAU_CFLAGS=
+ VDPAU_LIBS=-lvdpau
+ HAVE_VDPAU=no
+
+ saved_CPPFLAGS="$CPPFLAGS"
+ AC_CHECK_HEADER([vdpau/vdpau.h], [HAVE_VDPAU_H=yes])
+ if test -z "$HAVE_VDPAU_H"; then
+ dnl Didn't find VDPAU header straight away.
+ dnl Try /usr/include/nvidia. Need to clear caching vars first
+ AC_MSG_NOTICE([VDPAU header not in standard path. Checking /usr/include/nvidia])
+ unset ac_cv_header_vdpau_vdpau_h
+ unset ac_cv_header_vdpau_vdpau_x11_h
+ VDPAU_CFLAGS="-I/usr/include/nvidia"
+ VDPAU_LIBS="-L/usr/lib/nvidia -lvdpau"
+ CPPFLAGS="$VDPAU_CFLAGS $saved_CPPFLAGS"
+ AC_CHECK_HEADER([vdpau/vdpau.h], [HAVE_VDPAU_H=yes])
+ fi
+ AC_CHECK_HEADER([vdpau/vdpau_x11.h], [HAVE_VDPAU_X11_H=yes])
+ CPPFLAGS="$saved_CPPFLAGS"
+
+ if test "x$HAVE_VDPAU_H" = "xyes" -a "x$HAVE_VDPAU_X11_H" = "xyes"; then
+ dnl Found the headers - look for the lib
+ AC_MSG_NOTICE([VDPAU headers found. Checking libraries])
+ saved_LIBS="$LIBS"
+ LIBS="$VDPAU_LIBS $saved_LIBS"
+ AC_CHECK_LIB(vdpau,vdp_device_create_x11,[HAVE_VDPAU="yes"])
+ LIBS="$saved_LIBS"
+ fi
+ if test "$HAVE_VDPAU" = "yes"; then
+ AC_MSG_NOTICE([Found up to date VDPAU installation])
+ AC_SUBST(VDPAU_CFLAGS)
+ AC_SUBST(VDPAU_LIBS)
+ fi
+])
+
else
dnl not building plugins with external dependencies,
@@ -1484,6 +1522,7 @@ AM_CONDITIONAL(USE_XVID, false)
AM_CONDITIONAL(USE_WILDMIDI, false)
AM_CONDITIONAL(USE_WININET, false)
AM_CONDITIONAL(USE_ACM, false)
+AM_CONDITIONAL(USE_VDPAU, false)
fi dnl of EXT plugins
@@ -1546,8 +1585,10 @@ dnl po/Makefile.in
AC_CONFIG_FILES(
Makefile
+common/Makefile
common/shave
common/shave-libtool
+common/m4/Makefile
gst-plugins-bad.spec
gst/Makefile
gst/aacparse/Makefile
@@ -1555,8 +1596,6 @@ gst/adpcmdec/Makefile
gst/aiffparse/Makefile
gst/amrparse/Makefile
gst/autoconvert/Makefile
-gst/legacyresample/Makefile
-gst/liveadder/Makefile
gst/bayer/Makefile
gst/camerabin/Makefile
gst/cdxaparse/Makefile
@@ -1570,7 +1609,9 @@ gst/frei0r/Makefile
gst/h264parse/Makefile
gst/hdvparse/Makefile
gst/id3tag/Makefile
+gst/legacyresample/Makefile
gst/librfb/Makefile
+gst/liveadder/Makefile
gst/mpegdemux/Makefile
gst/mpegtsmux/Makefile
gst/mpegtsmux/tsmux/Makefile
@@ -1583,6 +1624,7 @@ gst/nuvdemux/Makefile
gst/pcapparse/Makefile
gst/qtmux/Makefile
gst/rawparse/Makefile
+gst/real/Makefile
gst/rtpmanager/Makefile
gst/rtpmux/Makefile
gst/scaletempo/Makefile
@@ -1597,7 +1639,6 @@ gst/tta/Makefile
gst/valve/Makefile
gst/videosignal/Makefile
gst/vmnc/Makefile
-gst/real/Makefile
gst/xdgmime/Makefile
gst-libs/Makefile
gst-libs/gst/Makefile
@@ -1617,18 +1658,23 @@ sys/oss4/Makefile
sys/osxvideo/Makefile
sys/qtwrapper/Makefile
sys/vcd/Makefile
+sys/vdpau/Makefile
sys/wasapi/Makefile
sys/wininet/Makefile
sys/winks/Makefile
sys/winscreencap/Makefile
+tests/Makefile
+tests/check/Makefile
tests/examples/Makefile
+tests/examples/camerabin/Makefile
tests/examples/directfb/Makefile
tests/examples/mxf/Makefile
-tests/examples/shapewipe/Makefile
tests/examples/scaletempo/Makefile
+tests/examples/shapewipe/Makefile
tests/examples/switch/Makefile
-ext/amrwb/Makefile
+tests/icles/Makefile
ext/alsaspdif/Makefile
+ext/amrwb/Makefile
ext/assrender/Makefile
ext/apexsink/Makefile
ext/bz2/Makefile
@@ -1639,7 +1685,6 @@ ext/dirac/Makefile
ext/directfb/Makefile
ext/divx/Makefile
ext/dts/Makefile
-ext/metadata/Makefile
ext/faac/Makefile
ext/faad/Makefile
ext/gsm/Makefile
@@ -1650,7 +1695,7 @@ ext/ladspa/Makefile
ext/lv2/Makefile
ext/libmms/Makefile
ext/Makefile
-ext/nas/Makefile
+ext/metadata/Makefile
ext/modplug/Makefile
ext/mpeg2enc/Makefile
ext/mimic/Makefile
@@ -1658,6 +1703,7 @@ ext/mplex/Makefile
ext/musepack/Makefile
ext/musicbrainz/Makefile
ext/mythtv/Makefile
+ext/nas/Makefile
ext/neon/Makefile
ext/ofa/Makefile
ext/resindvd/Makefile
@@ -1674,12 +1720,7 @@ docs/Makefile
docs/plugins/Makefile
docs/plugins/figures/Makefile
docs/version.entities
-common/Makefile
-common/m4/Makefile
m4/Makefile
-tests/Makefile
-tests/check/Makefile
-tests/icles/Makefile
win32/common/config.h
)
AC_OUTPUT